- The LaST Upgrade -


"The Story- Where everything goes wrong"

Chris Swinson 2013



I was on of the first CT60 buyers back in the day. however I never got CT60 to work dispite sending my falcon back to Rudolphe and spending endless hours trying to get to GEM without crashing. Since around 2004 my Falcon simply has not been used as I gave up with it. However now in 2013 I decided to give it another go.

This page is not a guide to update CT60. This page shows everything which went wrong while I was "trying" to update the CT60. If you are looking for a CT60 firmware update page click HERE.

The firmware is 5E and 5L, where as on CT60 site it says firmware is 5E and 5M. So I decided to update my firmware to what its supposed to be, as no doubt I will end up running into some endless loop of problems again before too long.

For those who want to skip the waffle click HERE. I suggest you read everything before attempting to "follow" my instructions as I wrote this page as I was going though it all so I did not miss anything :) I will try and write a quick guide once its all done, so people do not have to read though pages of things going wrong to update the CT60 :)

Guides I used to get "some idea" of what to do are HERE and HERE

I really wanted the 060 CPU which ran at 100mhz. At the time Rodolphe offered a exchange with additional cost to upgrade the CPU to later mask, but I could not afford it at the time so I was stuck with the 50mhz mask. In anycase, I did spend much time hunting for the later mask but gave up. It seems there are a lot of fakes on the market, which does not help in tracking down a genuine 100mhz mask.

Rodolphe said at the time..

I have some big problems with the lastest 25 CPU I received for your friends that ordered a CT and are waiting for it ! The CPU were marked correctly 71E41J mask on the right corner, so they should be REV.6 ! But in fact, according to the internal PCR the CT60 read on boot, they are REV.5 (G65V mask).... and so are not able to run more than 75 MHz instead of the 95 MHz...

He recently found an other furnisher with MC68060RC50 and 71E41J mask and he sent me the photo, but the MC68060RC50 reference is again white printed, not engraved... and the left border is S23328-002, and I think it may be again a bad and false REV.6 CPU.
I was thinking all rev.6 have MC68060RC50 reference that is engrave, never white painted ! For me white painted is a false rev.6, a rev.1 or 5 that was erased and reapainted with a dummy reference and mask as it is practiced by some not honnest guys and companies...

He sent me these images as shown below.

Above Supposed FALSE 71E41J Mask. S23328-002


Above Supposed TRUE 71E41J S23328-004


I found a thread HERE (french) where someone had been investigating the fakes.

In case the blog vanishes in future.. I somehow found the page had uploaded itself to my server and can be found HERE also translated.

For those too lazy to read it all, it would simply seem any 060 CPU's with 002 on them are fake CPU's regardless of the MASK number printed on them. 004 is a genuine mask, and 006 is a later mask still. I presume the 006 is improved device , possible it could run faster and cooler over the 004.

I would really like to find a 006 mask cpu, though these are near impossible to fine and they seem to go for silly prices of £100 or more :( But in anycase, I hope this information I have collected is of use to someone.


Meanwhile, while I was bored waiting for the software to download I did some IDE speed testing.
I used PP Speed test program which can be found HERE
So I clicked the ACSI transfer rate test, and got "device not responding" which is true since I did not actually have anything plugged in! Shortly followed by the first CT60 crash of the day.

Above test was IDE Transfer rate. 3580 KB/sec at 0.2mS.

Below test was C Partition tests 3442 KB/sec at 5.4mS

The card used was a LEXAR PREMIUM SERIES 4GB 200X CF CARD.

As I was still waiting for the software to download I also tried a SANDISK EXTREME III 4GB 30MBs CF card.

Firstly I installed HD8.47 drivers again, and rebooted. When I got to GEM I got Drive A not responding type message, actually there was no floppy in the drive. So I clicked Cancel then CT60 crashed again.


Going by the speed it was scrolling up the screen, job well done as the CT60 can sure crash with speed :)

Transfer rate of the Sandisk CF was 3494KB/sec at 0.8mS. (LEXAR 3580 KB/sec at 0.2mS. )

The Partition Transfer rate was 3287KB/sec 6.3mS. (LEXAR 3442 KB/sec at 5.4mS)

So it would seem the LEXAR is a fast card than the Sandisk EXTREME III.


The first step is to download the software. Its a huge >3GB file which can be found on http://www.xilinx.com/support/download/index.htm Unfortunatly you have to register and the registration email takes about 15mins to arrive (for those impatient people like me). Its best to start downloading the software before doing anything else.
A few years back these were around £30!! but now you can pick them up for under £10. It was the cheapest one around at the time, and probably still is. The only problem with it, it has a 10pin ribbon cable which in no way shape or form fits into the CT60 pinout. So some cable editing was needed..

Sorry for the poor image quality! What I did was to cut off one end of the ribon cable and solder the wires onto a SIL socket type connector.

The images below helped me work out how to rearrange the pins. For some reason the images found their way onto my server and onto this page without my knowledge and are totally not "stolen" ;)

The white plastic was super-glued to the connector and cable to hold it all in place. Then lots of PVC insulation tape wrapped around it (aka bodge tape). Of course no project is really complete without super-glue and bodge tape :)

Finally after the software downloaded.. (SKIP THE BELOW MISTAKES)

You go though what seems like endless terms screens and all that kinda thing. It puts me off using software and wants you to sign up with one of those "useage" stat things so they can keep a eye on what you are doing. You cannot install the software unless you agree to it, which I do not like companies spying on me, but oh well.

During install you get 4 options, I choose the Vivado WebPACK option. A few more screens later and you are ready to actually install the thing. Its worrying to think they recommend to disable your anti-virus to speed up the install. I think installing windows takes less time than installing the software! Hopefully I will not have to have it cluttering up my system for too long anyway.

So now we get a license option, as I have no clue at all about any of what its on about, I choose the top option. How it reads you can use it for 30 days then your stuffed.


So when I loaded up the software I get a option screen to what project to "create". After much going though everything I was totally lost. According to THIS guide I needed the IMPACT software, which is no where to be found. So either the software has totally changed or I have "missed something". Reinstalling the software forced me to uninstall it all, then I choose the "Vivado System Edition" option. That one had no more options in either.

I looked at the guide and it said "ISE" Looking at the Xilinx site theres a different "tab" with Vivado Design Suite or ISE Design Tools. So it would appear I have downloaded the wrong software package. In fact the ISE tools is even larger than the first one! So lets try again...

Uninstalling the whole stuff I had just spent installing AGAIN. It casued my PC to hang during install and uninstall. I have a fast 4ghz quadcore with a 400MB/sec SSD and it managed to hang that system, so fear the thought of installing it on a slower/older pc!

So I started to download this.

Full Installer for Windows (TAR/GZIP - 5.89 GB)

MD5 SUM Value: 26b5823dd1113ce6b2fabced65dc5687


The software as used in the guides suggests version 13.3. So of course wanting the latest version, Its what I downloaded, which will probably result in chaos, but thats the idea of my "guide" to rule out the mistakes ;)

Meanwhile I realised I did not have the driver software for the USB BLASTER. Turns out you need to download this

Quartus II Programmer and SignalTap II
Size: 136.6 MB MD5: F2F4B22D649DF1CB38AC6360474C70CC

From HERE I have uploaded just the drivers HERE is anyone needs them. Password is my forum name.

Finally I got the drivers installed ( after I spent over a hour trying to find the USB cable that is!)

While the other software was STILL downloading, I gave the Quartus software a look.


I first tried with the Falcon OFF and it did nothing with the programmer plugging in, so I turned the Falcon ON and I did get the 2 IC's listed in the Quartus software :) I think the problem of it not showing chip numbers is that its Altera software not xilinx. However, inital tests shows that it has found 2 chips on the falcon, so the first good sign of today so far!
So several MORE hours later.. The software took half hour or so to install. I installed the "WebPack"

The "inpact" software was found in

START > Programs > Xilinx Design Tools > Xilinx ISE Design Suite 14.6> ISE Design Tools > 32 bit Tools > iMPACT

I pretty much think its a good idea to create a shortcut to desktop rather than going though all those menus!

So I loaded the software FINALLY after a epic lasting 11 hours, and nothing happens!!! I fiddled with the options and it simply cannot find the USB BLASTER. BUT, it worked in the Altera software, which I then noticed was stamped onto the USB BLASTER box :-( So in other words, Altera stuff does not work with xilinx stuff. Which sounds pretty stupid really, though this morning when I started all this, I had no idea that altera and xilinx were even 2 different manufactures having never used any of their stuff before! AAARRRGGHHHHH!!!!!!

So I guess its back to china to buy another USB box :(

So I paid for 3 day delivery so I did not have to wait months and it came sooner than expected :)

I like that the pinouts are printed on the top of the box. As suspected the cables provided did not fit the CT60. So I cut the wires off and made my own. It is probably worth mentioning that the "dupot" cables would have been easier, in which case I wouldnt have had to make my own cable. Though it was the only box with quick delivery so its the one I went for.

So I finally got the new box. Made a new cable as shown above. As mentioned before, no project is complete without superglue and PVC bodge tape!

Plugging in the USB box and windoze found the hardware and installed it all ok. So when I launched IMPACT software, it simply did not find the cable. I played around all the cable options and bascially gave up after half hour. The software kept wanting a host name, I put one in, and it still kept saying the same thing. It does not give me faith in using the software when it tells me to do something I have done. Though I could be using it wrong!


So I checked the CD which came with the box, and it had Version 13.1 on it. Which would seem to be the version the other guides use, maybe something more to it in using that version ? So after half hour later uninstalling the 14.6 version, and installing the 13.1 version. Now I know why I simply put off trying to update the CT60 for so long!

So follow though all the screens, I choose the "WebPack" option as presumably it installs less clutter.

So after install I get the below set of options again..

...which did not work. So I tried the 3rd option down and that one seemed to work. So what happend next..

I choose "create a new project" and then got the screen below.

So great I thought and clicked OK..


I tried with the Falcon on and off, and messed with options and still no luck. Considering one guide said it would only take 5mins and its now been 2 days...I was starting to think with all the time and money spent on this that it probably would have been cheaper to send it to Rodolphe to update it for me!

So I think decided to uninstall the USB hardware drivers and use "Driver Cleaner" to clean out the current drivers..Which did not show in the list anyway :-\ I tried to install the drivers form the CD which came with the box, though I am unsure if it found them on there or not. I kept on trying but at this point I assume either I am doing something wrong, or this USB box is simply faulty. Considering the Alera one went perfectly ok I think I am liking their stuff much better at the moment!

I re-checked the wiring on my cable and all seemed ok. I did notice that when the box is connected there is a red light on it, but when I turn on the falcon, the light goes green. So it would appear the box is working to some degree. Though the software still refuses to see the cable.

I went though all the .inf files are tried to manually add them to the cable hardware and it would not accept it. So it seems that there is no actual software on the CD for the hardware. however windows did pick it up initally anyway. I tried installing all drivers I could find, I found a 02 and 03 driver, neither of them worked. I tried the Altera software and box again, and it found the 2 chips on CT60 so at least I knew I hadn't broke anything meanwhile.

At this point I had run out of things to try. After spending most of the time on Google looking for any clues, there wasn't anything which helped. So as a last resort I installed V14... again.. It looked like it installed in another folder so it shouldn't conflict with V13 files. Hopefully my C: drive will not run out of space installing this "bloatware"... Going by the minimum install was like 13GB, it does seem just a lot of stuff to simply program chips! I know there is other software included to but still... 13GB ?? Its not even got fancy 3D graphics or anything!

Snooping around I found versions versions of "WinDriver" Jungo software. I tried them all with no luck either. I went to their website to see if there was a later version, which there was , with millions of "bug fixes" and updates etc, only problem was it was $3,999. To which seems a lot to pay out to program 2 chips! For that money I could probably have a new falcon built from scratch with all the updates.

So now with V14 installed again, still the same problems. I tried going though all the cable options, reinstalling drivers etc and nothing works. At this point there is nothing more I can think of doing other than spending more time on Google looking for any possible clue as to what the problem is. I am assuming the USB box is ok as the light goes green when its plugged into the CT60, the PC finds the USB box so assume that end is ok. Drivers and software all seem ok, so I just put it down to "just another piece of software which doesn't work right". Considering I have had many programmers plugged into the same PC for years and never had any troubles like I have had with this xilinx stuff, its put me off ever using anything to do with them in the future. The Altera software is GB's smaller and it worked right from the start. However, I cannot use the Altera stuff to program the CT60 so it looks like it will just have to stay broken. Chances are the new firmware probably wouldnt fix all the crashes I was getting anyway, though I guess I will never know.

I had the idea to uninstall everything i could find to xilinix then reinstall version 13. I also thought to install it on my laptop as its totally different everything! Was great that the CD supplied wouldnt read on the laptop CDROM :-( So I thought I could copy all the files to my USB stick, which I later realised was at my girlfriends. So I then spent the next hour finding all the bits to a external USB CDROM drive so I could actually install the software on my laptop. Considering it takes ages to install on my PC, it would probably take hours to install on my laptop...

..Sometime later..

On my main PC the hardware was not automatically installed like last time, I found the drivers in C:\Xilinx\13.1\ISE_DS\common\bin\nt and it installed from there OK. However, at no suprise, it still would not connect to the cable. So I have just uninstalled the software, I should say for the last time as I have no intentions of installing it again! I think it may not really be intended for USB stuff. It seems to try harder in looking for the LPT ports more than anything. I am not going to start with LPT ports simply due to the fact my PC has not had one for the past few years and I really do not want to spend more money buying PCI LPT cards and yet another programmer on the off chance that the software is going to work.

Some time later...

It looks like the cable was found on the laptop!! Though I did notice it installed 2 things this time. One was a "xilinx USB cable" and the other message I got before "USB platform firmware loader".

The software runs like a dog on the laptop. click something wait 10 seconds kinda thing. So far it is saying write command failed, many devices found, unable to identify and all that kinda thing. So I suppose its progress, instead of it not working full stop, I am getting many errors now! Not sure if thats progress, but at least it seems to be doing more on the laptop. I seem to get "write cmd failed 20000015" millions of times. I don't know why.

So after much messing about, I unplugged the CT60 cable and plugged it in again and it found 4 chips "unknown" and asked me a lot of questions that I had no idea what it was on about. After going though those options it just stated with cable not found again!


OK! So heres where it starts getting "good".

First of all, it seems the software and USB box are buggy at best. The software on my main pc did not appear to install the cable software correctly. On my main PC in Device manager, under "programming adapters" if it says "USB platform firmware loader" Then I would assume it simply isn't going to work and you might as well forget it.

Now on my Laptop, it installed the same thing first (USB platform firmware loader) But then it installed something right after "xilinx USB cable". Which is what shows up in device manager. I will assume if you do not see that then you will simply have to try installing the software on another PC.

Sorry for the poor images, I was in a rush so had to take images on my digicam..

First of all, I think its a good idea to install the software ( I used V13.1) first, then unplug the USB box for a few second then plug the USB cable back in. Then load the Impact Software.

It will ask to create a new project, so choose that option, and on the next screen STOP! You need to now plug in the JTAG cable into the CT60 and turn on the Falcon. Wait about 30 seconds and then click OK in IMPACT (leave the top option selected for auto detect).

The above method has to be followed EXACTLY. It may not work 100% of the time as I found out below!


I think if you get this far its "almost" worked. What I did then was too simply unplug the CT60 cable and plug it back in again and I got the image below..


So 2 days solid work at FINALLY made progress.

So now I have been though all this, you can click HERE for the guide which assumes everything goes right. Then when it doesn't you can check if I had the problem and hopefully solve it :)

So did it solve my CT60 problems ?


Well no :-(

Thing is there, I have the desktop to open up drive A and drive C. Though I did not have a floppy in the drive, so when I click Cancel, it just crashes.

I have a feeling there was some software to run in the auto folder to stop things like that, but there seems to be little information on it all. I will try and find out and post any progress here as it happens...

At last I found the cause of the problem. This resistor looked like a "after thought", like it wasn't intended to be there. I asked on the Atari forum and people posted back that their own CT60/63 did not have that resistor. So I removed it, and CT60 booted right up and 99% of my problems went away!! FINALLY!

I emailed Rodolphe about this resistor and is as follows..

CS - I do not think any other CT60 owners had this resistor ? I asked on the forum and nobody seen it before.
RC - You're wrong !
RC - Many people have this resistor and it is indicated on my web site...
RC - I have several CT here with this resistor !
RC - This resistor is used since 2004 ! And I never heard problems with

So make of it what you will. With nobody else having this resistor and not having the epic problems I had, then me removing the resistor and problems goign away, I think its clear the resistor was the problem.

I also found you need NVDI V503 in order for CT60 to function correctly. I uploaded a fixed version which will run from hard drive HERE. There is a update file in there too, but I was unable to get it to install. So not sure it it is really needed or not.

So now all fixed, time to find me a good REV6 CPU!!!!