- The LaST Upgrade -


"The PC USB Guide"

Chris Swinson 2013


Here is my Guide on how to program the CT60 firmware
using a USB xilinx programmer.

I suggest anyone who arrived here to click HERE and see all the problems I ran into before you consider following this guide.

Most images can be clicked on for larger resolution

First of all you need to download the software. The one I used was V13.1. Other versions *may* work but I have not tried them.

Latest versions.


Older version which I used 13.1


Full Installer for Windows ( - 3.88 GB)

MD5 SUM Value: 52dc020ad22df3710035753f46177c8c

I suggest due to its near 4GB size that you start downloading it and read the rest of the guide meanwhile :)

Goto the CT60 site and grab your 2 files, in my case I had a CT60 without CTPCI so I downloaded the ABE_V5M ; SDR_V5E files.


In case the CT60 site goes offine I uploaded the CT60/63 files HERE and CT60/63 CTPCI files HERE.

I would advise you always check the CT60 site for any possible updates.

Extract/copy the files to a folder you can find it such as C:\Xilinx\


The Xilinx box I got is as shown below.

I like that the pinouts are printed on the top of the box. As suspected the cables provided did not fit the CT60. So I cut the wires off and made my own.

It is probably worth mentioning that the "dupot" cables would have been easier, in which case I wouldnt have had to make my own cable. Though it was the only box with quick delivery so its the one I went for.

It is just a matter of matching the pins from the CT60 to the USB box :)

Pinouts for the CT60 as shown below. Image is of course not stolen ;)

The white plastic was super-glued to the connector and cable to hold it all in place. Then lots of PVC insulation tape wrapped around it (aka bodge tape). Of course no project is really complete without super-glue and bodge tape :)
When the software eventually finishes downloading, install it and follow the screens as shown below.
You want the top option.

You do not need the last option so untick the box!

Then just agree and follow though all the install hype and go put a cup of coffee on the go!

When the software eventually installs you get the above screen. The first option should work , if not try the 3rd one!

If you have not done so already, plug the USB programmer into the PC and it sohuld install the software automatically. If it cannot find the drivers they can be located here C:\Xilinx\13.1\ISE_DS\common\bin\nt

Once installed I advise you go into Device Manager and check that it shows the exact name as shown below.

It must say "xilinx USB cable", if it says "USB platform firmware loader" Then you may run into all the problems I had HERE .
Select "create a new project" then click OK.


The USB cable to the programmer must be connected (if it isn't already) THEN connect the JTAG cable to the CT60 and turn ON the Falcon. WAIT 30 seconds, then click OK on the IMPACT software.

If all goes well you should get the screen above. Notice the 2 chips and they must say XC95144XC on both chips.

If you got stuck at this point you should probably read my problems page HERE

Click YES.
The left chip is slected first and you need to find where you saved the CT60 files, (C:\Xilinx\ as per my suggestion earlier). The first IC turns green and you get the selector box where you need to select the ABE file (AB5M.jed) and click open.
The second chip will turn green and you select the second file, the SDR (SD5E.jed) and click open.
The next screen just check the tickboxes are correct and click OK. You should check DEVICE 1 and DEVICE 2 to make sure the tickboxes are the same. They should be by default anyway.
Now right click the first chip on the left and click ERASE.
Then it should say "ERASE SUCCEEDED"
Right click the second chip and click erase.
Then it should say "ERASE SUCCEEDED"

What I did then was to right click on both chips and verify the part was blank.

It is worth noting that as the Falcon is still ON, it will probably crash, screen go white, or garbage on screen , this is normal, DO NOT TURN OFF THE FALCON!
Then right click the left chip and click Program.
It will take a few seconds to program the chip on the CT60.
First one done :)
Now right click the second chip and click Program.
Again wait a few seconds while it programs the chip..
What I then did was to right click each chip again and choose Verify. Just to make 100% sure things have worked.

That's it! done :)

Your CT60 JTAG cable can be unplugged and the Falcon turned off. When you turn back on the falcon you should have the new firmware in use :)



In case anyone needs the older 103C firmware I have put the "kit" HERE

The firmware (at the time of writing) is 201 and I put the "kit" HERE (2.01 2011 July 27)

PLEASE NOTE THE ABOVE FILES ARE FOR CT60/CT63 WITHOUT CTPCI. The firmware is different for CTPCI with CT60.

V201 CTPCI files use boot.hex which can be found HERE

Latest firmware files (if any) can be found here along with CTCPI firmwares.

Extract the files onto a 1.44 floppy. I enclosed the cpx modules which were included in the 201 and 103C files. I am not sure if there is any difference between the cpx modules but I kept them seperate just in case.

Clean boot in 030 mode and run flash060.prg. I tried to program in 060 mode but it crashed half way and was much trouble to get it to work again. so ONLY do in 030 mode!

Then you get the above screen and you need to click the SOURCE box.
Locate the firmware file which is CT60TOS.BIN and click OK.

It will take some seconds to load up (assuming your runing from floppy).

Once loaded click PROGRAM button.

It will only take a few seconds to program. The circles at the bottom is the "progress bar".
There is nothing to actually tell you it has finished other than the progress bar being full. The "busy bee" mouse will go back to the normal pointer. Turn your falcon off and on again making sure you are now in 060 mode.

Done :)

All being well you now have the latest 201 firmware.