H5 MIDI AMP FIX WIP

Information and progress towards the H5 board.
Locked
User avatar
exxos
Site Admin
Site Admin
Posts: 18652
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

H5 MIDI AMP FIX WIP

Post by exxos »

I copied some of this from my build thread as it will likely get lost otherwise... This does not really count as a issue as such, but people using MIDI module may well find a volume is a lot lower than the YM audio..

Its not overly a massive issue, but the MIDI output needs a preamp to get it up to the YM sound level. So I am in the middle of redesigning the audio circuit to do away with the single transistor amp, which really just seems to act as a buffer, for a dual op amp where I can use one amp to increase the volume of the MIDI, and then use a second amp as the main output audio driver.

The blue line is 5 kHz MIDI simulation waveform. The green is one 1Khz YM sound chip simulation waveform. The red is the combined output of both. I actually made the final amp more of a divide by two because the combined audio input of both of them was taking it to well over one volt which would mean the sound level would be twice as loud as it is now which I think would be too much. In any case the volume level can be controlled by altering a resistor on the board so it should not be too much hassle to just do it by ear anyway.

Capture.PNG
Capture.PNG (249.03 KiB) Viewed 1599 times
Capture.PNG
Capture.PNG (35.42 KiB) Viewed 1599 times

I have got 30 of these made, I have no idea if they will be correct until they are tried.. Ultimately if this patch board works fine then the amp circuit will be redesigned on a future H5 series board to use the patch board amp instead. The board is basically 2 cm² as that is the smallest board size I can get assembled.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 18652
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: H5 MIDI AMP FIX WIP

Post by exxos »

I have copy/pasted the H5 AMP FIX into a new Eagle file. Added some connectors to replace the previous "Winamp" amp boards.

OSHpark can make the PCB. LCSC parts are listed in the BRD file if you click on them.

Capture.PNG
Capture.PNG (104.64 KiB) Viewed 161 times
C3_AMP1.zip
(9.44 KiB) Downloaded 8 times

Of course this is untested, and no i'm not listing mouser parts or other suppliers.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Locked

Return to “H5 Phoenix Platform Edition”