C100167 MEGA ST REV 4

MEGA ST motherboards.
Locked
User avatar
exxos
Site Admin
Site Admin
Posts: 18961
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

C100167 MEGA ST REV 4

Post by exxos »

mega4.jpg
mega4.jpg (780.04 KiB) Viewed 101 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
rubber_jonnie
Moderator
Moderator
Posts: 7002
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: C100167 MEGA ST REV 4

Post by rubber_jonnie »

My REV 4 showing the grubbiness on the PCB and the missing sound chip.
IMG_20191011_145311.jpg
IMG_20191011_145311.jpg (562.23 KiB) Viewed 5808 times
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
PaulJ
Posts: 1568
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: C100167 MEGA ST REV 4

Post by PaulJ »

Jon, looks like the glitter is gone. :dizzy: Wonder what other issues it has?
User avatar
rubber_jonnie
Moderator
Moderator
Posts: 7002
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: C100167 MEGA ST REV 4

Post by rubber_jonnie »

Former owner said he had problems with the Glitter, something I intend to rectify 😁

Once the RAM and Floppy are sorted, glitter is next. Sound chip is already done, but not tested.

I was hoping to get a KB wired up temporarily, but a problem with our central heating not working diverted my attention!
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
rubber_jonnie
Moderator
Moderator
Posts: 7002
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: C100167 MEGA ST REV 4

Post by rubber_jonnie »

Here's the after pic:

IMG_20191019_161452.jpg
IMG_20191019_161452.jpg (500.64 KiB) Viewed 5713 times

Glitter fitted, sound chip fitted, new floppy plug fitted and header fitted for new RTC power lead. Not to mention fixing the bent ROM pins!

Mostly running fine, got to run Gembench and see what's going on.

TOS says 2MB, Diag cart says 4MB, so that's odd, but otherwise much better than when it arrived.
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
stephen_usher
Posts: 3480
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: C100167 MEGA ST REV 4

Post by stephen_usher »

:dualthumbup:
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.
jwd
Posts: 17
Joined: Tue Jun 11, 2019 11:23 am

Re: C100167 MEGA ST REV 4

Post by jwd »

That looks like a Mega 2 only because in the Spectre GCR manual it states that 2x SGS buffer chips needs replacing for stability (in general not just for Spectre GCR) :

Mega 2 problems.png
Mega 2 problems.png (234.5 KiB) Viewed 223 times

Can't see those SGS buffer chips in any of the other motherboard pics.
User avatar
exxos
Site Admin
Site Admin
Posts: 18961
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: C100167 MEGA ST REV 4

Post by exxos »

Interesting article I had not seen it.Thanks for posting it.

I would surmise that changing the bus pullups would have a better / similar effect. Sounds like the age-old problem of changing tolerances of circuit just enough to get it working kind of fix.

I don't know how that the thing fits but.. The pulldown current of the LS chips is typically like 20mA or more. The pullup , at least on the CPU bus, is done via the 10K pullups, which is 0.5mA! So driving the capacitance on such a weak pull-up is basically madness hence why I have been saying for years they need changing because they are unstable.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
ijor
Posts: 203
Joined: Fri Nov 30, 2018 8:45 pm

Re: C100167 MEGA ST REV 4

Post by ijor »

jwd wrote: Mon Jul 25, 2022 2:11 pm That looks like a Mega 2 only because in the Spectre GCR manual it states that 2x SGS buffer chips needs replacing for stability (in general not just for Spectre GCR) :
Very interesting document and info!
exxos wrote: Mon Jul 25, 2022 2:23 pm I would surmise that changing the bus pullups would have a better / similar effect. Sounds like the age-old problem of changing tolerances of circuit just enough to get it working kind of fix.

I don't know how that the thing fits but.. The pulldown current of the LS chips is typically like 20mA or more. The pullup , at least on the CPU bus, is done via the 10K pullups, which is 0.5mA! So driving the capacitance on such a week pull-up is basically madness hence why I have been saying for years they need changing because they are unstable.
I think they are two separate issues, even when possibly related. This is not an open drain bus. The pull-ups are there just to avoid the signals being floating when the bus is idle. They don't actually pull-up the bus (not significantly) when an active transaction is being performed. The CPU, or the peripheral, actively drives the bus both low and high.
http://github.com/ijor/fx68k 68000 cycle exact FPGA core
FX CAST Cycle Accurate Atari ST core
http://pasti.fxatari.com
Locked

Return to “MEGA ST”