The Cosmic Puppet's Universe.

Blogs & guides and tales of woo by forum members.
User avatar
Cosmic Puppet
Posts: 1506
Joined: Fri Aug 02, 2019 1:03 am
Location: West Yorkshire
Contact:

Re: The Cosmic Puppet's Universe.

Post by Cosmic Puppet »

exxos wrote: Thu Jun 23, 2022 4:45 pm
Cosmic Puppet wrote: Thu Jun 23, 2022 4:44 pm Assuming something's been disturbed (apart from me) by 'manhandling' the machine. Any ideas how I could have caused it. Some part of my machine being flakey maybe?
Maybe bad contact on the GLUE ?
I'll check that if I get any problems. Machine is definitely showing signs it's been exposed to planet Earth. Top of the Floppy Disk no longer looks sparkly new, so probably some oxidisation going on. My GLUE does have a clip over it but will still check it first sign of issues.

Not even gonna breath heavy near my Atari just now though. :lol:
US Atari 520 STFM (C070523-001 REV.D1) 4MB Marpet Upgrade, TOS 1.04, EmuTOS 20211020, Ultrasatan, PP Driver, Original Floppy Disk Drive, NEC Multisync EA193Mi Monitor.
User avatar
Cosmic Puppet
Posts: 1506
Joined: Fri Aug 02, 2019 1:03 am
Location: West Yorkshire
Contact:

Re: The Cosmic Puppet's Universe.

Post by Cosmic Puppet »

It says here that the DMA 'oversees' the printer. Is the STE DMA compatible with an STFM?

Asking in-case folks assumed I was talking about an STE.

Does anyone have a C398739-001A DMA running in a regular STFM?

Screenshot 2022-06-23 172740.jpg
Screenshot 2022-06-23 172740.jpg (240.36 KiB) Viewed 145 times
Screenshot 2022-06-23 172740crop.jpg
Screenshot 2022-06-23 172740crop.jpg (5.93 KiB) Viewed 145 times
US Atari 520 STFM (C070523-001 REV.D1) 4MB Marpet Upgrade, TOS 1.04, EmuTOS 20211020, Ultrasatan, PP Driver, Original Floppy Disk Drive, NEC Multisync EA193Mi Monitor.
User avatar
exxos
Site Admin
Site Admin
Posts: 18644
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: The Cosmic Puppet's Universe.

Post by exxos »

Cosmic Puppet wrote: Thu Jun 23, 2022 9:15 pm It says here that the DMA 'oversees' the printer.
The only thing connected to the DMA chip is the hard drive port and floppy controller. As posted before, the sound chip does the printer.
Cosmic Puppet wrote: Thu Jun 23, 2022 9:15 pm Is the STE DMA compatible with an STFM?
Should be.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Steve
Posts: 2006
Joined: Fri Sep 15, 2017 11:49 am

Re: The Cosmic Puppet's Universe.

Post by Steve »

FYI in that image it says it oversees 'laser printer' which is an entirely different beast to your parallel printer. Laser printers do connect via the DMA through a special interface device. So nothing related to your issue.
User avatar
Cosmic Puppet
Posts: 1506
Joined: Fri Aug 02, 2019 1:03 am
Location: West Yorkshire
Contact:

Re: The Cosmic Puppet's Universe.

Post by Cosmic Puppet »

Okay, thanks guys. :| I realise how this could be annoying.

Just bugs me that I have no idea why everything is working when yesterday it wasn't.

As usual it should be more palatable after a sleep.

:comp:
US Atari 520 STFM (C070523-001 REV.D1) 4MB Marpet Upgrade, TOS 1.04, EmuTOS 20211020, Ultrasatan, PP Driver, Original Floppy Disk Drive, NEC Multisync EA193Mi Monitor.
User avatar
Cosmic Puppet
Posts: 1506
Joined: Fri Aug 02, 2019 1:03 am
Location: West Yorkshire
Contact:

Crazy floppy issue seems to be fixed.

Post by Cosmic Puppet »

I can format a floppy in TOS 1.04 with or without hard disk on, plugged in or out and then read it from EmuTOS running from UltraSatan (transfer files back and forth and also between the PC) Format in EmuTOS and still runs and swaps files when run on TOS 1.04 and between PC. Formatting in TOS 1.04 and then trying to use on the hard disk setup used to brick the floppy disk.

Tried every combination I can think of and haven't been able to make it fail! 8-)

My IMP DMA seems to have done the trick (along with mandatory fixes)
US Atari 520 STFM (C070523-001 REV.D1) 4MB Marpet Upgrade, TOS 1.04, EmuTOS 20211020, Ultrasatan, PP Driver, Original Floppy Disk Drive, NEC Multisync EA193Mi Monitor.
User avatar
rubber_jonnie
Moderator
Moderator
Posts: 6832
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: The Cosmic Puppet's Universe.

Post by rubber_jonnie »

If it is working, I'd tend not to question things. You've made your fixes, everything works fine, don't give yourself headache by looking for more unless it still doesn't work.

It is very easy to go down the route of investigating a problem that no longer exists, or at least shows none of the original symptoms. It can be a huge time suck and all you end up doing is becoming very frustrated because the symptom has gone, and you're back at square one.

These machines can break just by handling the board, so the less you do of that the better. Trust me leaving it is your best option right now.
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
rubber_jonnie
Moderator
Moderator
Posts: 6832
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: The Cosmic Puppet's Universe.

Post by rubber_jonnie »

Cosmic Puppet wrote: Thu Jun 23, 2022 9:15 pm It says here that the DMA 'oversees' the printer.
It actually says it looks after the laser printer, which uses the SLMC 804 adapter that connects via ACSI, not LPT.

Normal LPT port printers are controlled by the sound chip as @exxos says.
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
Cosmic Puppet
Posts: 1506
Joined: Fri Aug 02, 2019 1:03 am
Location: West Yorkshire
Contact:

Re: The Cosmic Puppet's Universe.

Post by Cosmic Puppet »

rubber_jonnie wrote: Fri Jun 24, 2022 9:20 am If it is working, I'd tend not to question things. You've made your fixes, everything works fine, don't give yourself headache by looking for more unless it still doesn't work.

It is very easy to go down the route of investigating a problem that no longer exists, or at least shows none of the original symptoms. It can be a huge time suck and all you end up doing is becoming very frustrated because the symptom has gone, and you're back at square one.

These machines can break just by handling the board, so the less you do of that the better. Trust me leaving it is your best option right now.
Thanks @rubber_jonnie

I did all those tests last night because the floppy and UltraSatan have never got along fully and was kinda in disbelief that I couldn't create a conflict, after it being that way since I bought the UltraSatan

It does prove that there isn't a one size fits all (apart from a newly designed board lol)

The DMA that I'm happy with cost £6.99. The one I didn't like is going for over seventy quid! and I hated it in my machine. Nothing but trouble since I put that in. Good riddance to it. And that original one was as useless as my original TOS 1.00 ROMs. Just created a tug of war between the UltraSatan and floppy drive. (still there after the fixes)

I count myself lucky though, because by what feels like a fluke (and mandatory fixes) I have ended up with everything working!

Just ordered another IMP DMA for spare.

Gonna be seeing my music collaborator and friend soon to work on already recorded and new stuff.

Gonna use this as a milestone for leaving all the TOS behind me. :lol:
US Atari 520 STFM (C070523-001 REV.D1) 4MB Marpet Upgrade, TOS 1.04, EmuTOS 20211020, Ultrasatan, PP Driver, Original Floppy Disk Drive, NEC Multisync EA193Mi Monitor.
User avatar
rubber_jonnie
Moderator
Moderator
Posts: 6832
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: The Cosmic Puppet's Universe.

Post by rubber_jonnie »

The main thing is that you're sorted, I hope the collaboration goes well :)
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
Post Reply

Return to “MEMBER BLOGS”