Falcon Csync video fault.

The latest tweaks and fixes to keep your machine running in tip-top shape.
User avatar
alienkidmj12
Posts: 284
Joined: Tue Aug 22, 2017 1:39 pm

Re: Falcon Csync video fault.

Post by alienkidmj12 »

im sure i have an issue with video on my falcon also, but not sure its the same one, my tt030 works with my dell etc fine, but the falcon seems to have issues, i even have a vga to rgb switch which doesnt seem to do much for me.
Roberto
Posts: 105
Joined: Wed Oct 13, 2021 8:37 pm

Re: Falcon Csync video fault.

Post by Roberto »

I have two Falcon 030s and both, when they are connected with the RGB cable via scart to an LCD TV (with the VGA cable I never noticed), I see that the background color changes, sometimes, from white to light blue with some interference. Yet that same cable used with any other Atari I have, works fine and with the same LCD TV. So should I change the orientation of that capacitor for both of my Falcons?
Steve
Posts: 2655
Joined: Fri Sep 15, 2017 11:49 am

Re: Falcon Csync video fault.

Post by Steve »

@Roberto no you should measure them both with a multimeter first, on some motherboard revisions they're OK but some they're not.
User avatar
Badwolf
Posts: 2280
Joined: Tue Nov 19, 2019 12:09 pm

Re: Falcon Csync video fault.

Post by Badwolf »

I have a (self-hacked) combined composite/RGB cable for my Falcon which needs an external power supply to switch to RGB mode. The composite is truly dire.

I wonder if this may be part of the issue (I had put it down to the terrible cable I employed).

Definitely worth a goosey.

Well found, @exxos.

BW
DFB1 Open source 50MHz 030 and TT-RAM accelerator for the Falcon
DSTB1 Open source 16Mhz 68k and AltRAM accelerator for the ST
Smalliermouse ST-optimised USB mouse adapter based on SmallyMouse2
FrontBench The Frontier: Elite 2 intro as a benchmark
User avatar
exxos
Site Admin
Site Admin
Posts: 24063
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Falcon Csync video fault.

Post by exxos »

Badwolf wrote: Mon Apr 15, 2024 1:32 pm Well found, @exxos.
:thumbup:

But just to be clear, I did not find this issue, @Steve asked me about it originally because the capacitor kept bulging.. So @Steve came across the problem first.

Though it's not the first time Atari have had caps in backwards in some machines (not limited to just the Falcon either).
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
alexh
Posts: 750
Joined: Tue Oct 17, 2017 4:51 pm
Location: Oxfordshire

Re: Falcon Csync video fault.

Post by alexh »

If this is confirmed. Does it deserve being part of the "mandatory fixes" for Falcon030?
Principal ASIC Engineer - SystemVerilog, VHDL
Thalion Webshrine - http://thalion.atari.org
STf,STfm,STe,MegaST,MegaSTe,Falcon060
A500+,A600,A4000/060,CD32,CDTV
User avatar
exxos
Site Admin
Site Admin
Posts: 24063
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Falcon Csync video fault.

Post by exxos »

alexh wrote: Mon Apr 15, 2024 3:23 pm If this is confirmed. Does it deserve being part of the "mandatory fixes" for Falcon030?
Yeah I will add it to the list. Though primarily it was a investigation into it rather than a "how to fix" article.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Steve
Posts: 2655
Joined: Fri Sep 15, 2017 11:49 am

Re: Falcon Csync video fault.

Post by Steve »

Don't forget @alexh @Roberto @exxos that isn't the only reversed cap on the Falcon motherboard: viewtopic.php?f=17&t=5989&p=94897
User avatar
exxos
Site Admin
Site Admin
Posts: 24063
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Falcon Csync video fault.

Post by exxos »

Steve wrote: Mon Apr 15, 2024 4:27 pm Don't forget @alexh @Roberto @exxos that isn't the only reversed cap on the Falcon motherboard: viewtopic.php?f=17&t=5989&p=94897
Thanks I will add it to the list.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Roberto
Posts: 105
Joined: Wed Oct 13, 2021 8:37 pm

Re: Falcon Csync video fault.

Post by Roberto »

Steve wrote: Sun Apr 14, 2024 4:20 pm @Roberto no you should measure them both with a multimeter first, on some motherboard revisions they're OK but some they're not.
So I should only test with a multimeter if I actually find a positive value on the "+" pin of the capacitor and a negative value on the "-" pin. Right?
Post Reply

Return to “TWEAKS & FIXES”